
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200612002233
template: 
currentrequest: /apps/pbcs.dll/article?avis=IO&date=20200611&category=SPORTS&lopenr=200619908&Ref=AR
currentrequestunmodified: /sports/20200611/preps-with-potential
@templatetype: /apps/pbcs.dll/article?avis=IO&date=20200611&category=SPORTS&lopenr=200619908&Ref=AR
@pagetype: article
app version: 2.0.462
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="The Clay County Advocate - Press-Flora, IL" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Preps with potential - Sports - The Clay County Advocate - Press-Flora, IL - Flora, IL</title>
<!-- Meta Tags - Global Article6 guid: AADC72C0-CDE1-4622-9136-4D8325470A89-->
<meta name="description" content="The spotlight has shined on Ed Howard since the 2014 Little League World Series and continued last summer in showcase games at Wrigley Field and in Long Beach, Calif.The Chicago Cubs selected the shortstop from Mount Carmel High School with the 16th pick in the Major League Baseball amateur draft Wednesday night.The Chicago White Sox selected Garrett Crochet, a left handed pitcher from the University of Tennessee, while the St. Louis Cardinals picked Jordan Walker, a high school power hitter" />
<meta property="bt:pubDate" content="20200611T07:55:37Z">
<meta property="bt:modDate" content="20200611T07:55:00Z">
<meta property="bt:author" content="From wire services">
<meta name="twitter:title" content="Preps with potential">
<meta name="twitter:description" content="The spotlight has shined on Ed Howard since the 2014 Little League World Series and continued last summer in showcase games at Wrigley Field and in Long Beach, Calif.The Chicago Cubs selected the shortstop from Mount Carmel High School with the 16th pick in the Major League Baseball amateur draft Wednesday night.The Chicago White Sox selected Garrett Crochet, a left handed pitcher from the University of Tennessee, while the St. Louis Cardinals picked Jordan Walker, a high school power hitter">
<meta property="og:title" content="Preps with potential"/>
<meta property="og:description" content="The spotlight has shined on Ed Howard since the 2014 Little League World Series and continued last summer in showcase games at Wrigley Field and in Long" />
<meta name="author" content="From wire services">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.advocatepress.com/storyimage/IO/20200611/SPORTS/200619908/AR/0/AR-200619908.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.advocatepress.com/storyimage/IO/20200611/SPORTS/200619908/AR/0/AR-200619908.jpg">
	<meta property="og:image:width" content="3000">
	<meta property="og:image:height" content="2000">
	<meta property="vf:unique_id" content="siteIO-pub312-AADC72C0-CDE1-4622-9136-4D8325470A89">
	<link rel="canonical" href="https://www.advocatepress.com/sports/20200611/preps-with-potential"/>
<link rel="amphtml" href="https://www.advocatepress.com/sports/20200611/preps-with-potential?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.advocatepress.com/sports/20200611/preps-with-potential"
	},
    "headline": "Preps with potential",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.advocatepress.com/storyimage/IO/20200611/SPORTS/200619908/AR/0/AR-200619908.jpg",
       	"height": 2000,
       	"width": 3000
    },
    "url": "https://www.advocatepress.com/article/20200611/SPORTS/200619908",
    "thumbnailUrl": "https://www.advocatepress.com/apps/pbcsi.dll/bilde?Site=IO&Date=20200611&Category=SPORTS&ArtNo=200619908&Ref=AR",
    "dateCreated": "20200611T13:55:37Z",
    "datePublished": "20200611T13:55:37Z",
    "dateModified": "20200611T13:55:00Z",
    "author": [{"@type":"Person","name":"From wire services"}],
    "creator": "From wire services",
    "publisher": {
       "@type": "Organization",
       "name": "The Clay County Advocate - Press-Flora, IL",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.advocatepress.com/Global/images/head/nameplate/il-flora_logo.png"
       }
    },
    "articleSection": "Sports",
    "keywords": ["Sports","Top Stories","IL_Kewanee - starcourier.com"],
    "isAccessibleForFree": "false",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Daily Clay County Advocate-Press",
    "productID": "advocatepress.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="209802712401446"/>
<meta name="twitter:site" content="@CCAdvocatePress">
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.462/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
    .ad-300x250{
	    height: auto !important;
    }
    .pgs-dpg-flex, .pgs-dpg-card, div.pgs-dpg-card > iframe, div.pgs-dpg-flex > iframe{
		max-width: 350px;
		max-height: 460px;
		overflow: hidden;
	}
		/*==== for taboola ======*/
    	.article-newsletter-signup,#dialog-message{
	    	display: none !important;;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "https://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.advocatepress.com/news" target="_top">News</a></li><li><a href="https://www.advocatepress.com/sports" target="_top">Sports</a></li><li><a href="https://www.advocatepress.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.advocatepress.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.advocatepress.com/obituaries" target="_top">Obituaries</a></li><li><a href="https://www.advocatepress.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.advocatepress.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.advocatepress.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/ILOln" target="_top">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.advocatepress.com/subscribe?g2i_source=advocatepress.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=DCCA&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.advocatepress.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.advocatepress.com">
							<img class="mainheadnameplate" src="https://www.advocatepress.com/Global/images/head/nameplate/il-flora_logo.png"  alt="The Clay County Advocate - Press-Flora, IL" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.advocatepress.com/subscribe?g2i_source=advocatepress.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.advocatepress.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.advocatepress.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id='ad-base-leaderboard-article'>
	<div id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
	<div data-gh-object-loaded="false" 
		data-gh-object-offset="0" 
			data-gh-object='{"method":"__gh__webApp.utilities.adsRefresh.init","data":{"id":"baseLeaderboard-adRefresh","orgId":"baseLeaderboard","loadNow":"false","container":"ad-base-leaderboard-article"}}'
				class="ad-refresh" 
					data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Leaderboard","sov":"base ROS","refresh":"true"}' 
						data-dimensions="[[970,90],[970,250],[728,90]]" 
							id="baseLeaderboard-adRefresh" 
							 data-size-mapping="baseLeaderBillboardArticle" 
								 data-gh-object-parent-height="true"></div>
</div>

				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200611075537">
	<div class="inner">
		<h1 class="headline">Preps with potential</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.advocatepress.com/storyimage/IO/20200611/SPORTS/200619908/AR/0/AR-200619908.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">In this Feb. 17, 2019, file photo, Arizona State's Spencer Torkelson bats during an NCAA college baseball game against Notre Dame in Phoenix. Torkelson is only the third player in Pac-12 history to hit 20 home runs in back-to-back seasons. He was the No. 1 pick in Major League Baseball's amateur draft. [AP Photo/Rick Scuteri, File]</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					From wire services
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Thursday</h3>
							<span class="article-meta-date">Jun&nbsp;11,&nbsp;2020&nbsp;at&nbsp;7:55&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>The spotlight has shined on Ed Howard since the 2014 Little League World Series and continued last summer in showcase games at Wrigley Field and in Long Beach, Calif.</p><br><p>The Chicago Cubs selected the shortstop from Mount Carmel High School with the 16th pick in the Major League Baseball amateur draft Wednesday night.</p><br><p>The Chicago White Sox selected Garrett Crochet, a left handed pitcher from the University of Tennessee, while the St. Louis Cardinals picked Jordan Walker, a high school power hitter from Decatur, Georgia.</p><br><p>Here is a recap of the teams&#8217; selections:</p><br><p>&#8220;I&#8217;m excited to be a hometown guy,&#8221; said the 6-foot-2, 185-pound Howard, who starred at Mount Carmel until his senior season was canceled  because of the coronavirus pandemic. &#8220;I think it&#8217;s special. It&#8217;s unique. I&#8217;m ready to take on that challenge.&#8221;</p><br><p>Howard is the Cubs&#8217; first high school player drafted in the first round since outfielder Albert Almora Jr. in 2012.</p><br><p>The selection of Howard, an African American, occurred two days after team President Theo Epstein expressed a desire for him and the Cubs to become a more diverse organization.</p><br><p>&#8220;I hear what&#8217;s he&#8217;s saying,&#8221; Howard said. &#8220;I feel what&#8217;s going on in the world is crazy. We&#8217;ve all got to come together and realize that we&#8217;re all the same.&#8221;</p><br><p>But Howard&#8217;s talents and maturity stood out.</p><br><p>&#8220;He's got an electric skill set,&#8221; said Dan Kantrovitz, the Cubs&#8217; vice president of scouting. &#8220;He's a plus shortstop. He's got pop in his bat. He can run. He can impact the game in so many ways.</p><br><p>Howard batted .421 (48-for-114) with 11 doubles, four triples and three homers in 35 games in his junior season, and he was regarded as the top defensive high school shortstop in the draft.</p><br><p>Howard played in the 2019 Under Armour All-America Game at Wrigley Field and was a member of Team USA&#8217;s 18-under club.</p><br><p>Crochet, who stands 6-foot-6, made 18 appearances, including six starts, for Tennessee in 2019. He finished second on the team with 81 strikeouts.</p><br><p>The White Sox took him 11th overall.</p><br><p>He was hit in the face with a line drive and suffered a fractured jaw but came back two weeks later and helped Tennessee to its first NCAA Tournament victory since 2005 by pitching two scoreless innings against North Carolina Wilmington, according to the Knoxville News Sentinel. Crochet missed three weeks this spring as a precaution with shoulder soreness, according to the News Sentinel. He returned and struck out six in three innings in his only outing of 2020.</p><br><p>Jordan Walker was wearing the Decatur (Ga.) High's No. 17 jersey with the pinstripes and "D" logo when the Cardinals introduced him as their first pick, 21st overall, in the 2020 MLB draft.</p><br><p>"I'm beyond excited to play &#8212; I'm ready," he said. "The minute I heard my name called I was jumping for joy."</p><br><p>The 6-foot-5, 220-pound Walker just turned 18 and has committed to Duke. Scouts believe he'll stack strength onto his frame and catapult swing without slowing his innate athleticism. The Cardinals were referred to his "high ceiling" as well his ambition and off-field, academic acumen.</p><br><p>Walker's father, Derek, spoke at length Wednesday night about how the family has prioritized his son earning a college degree. He called his wife, Katrina, "professor" during his explanation. She earned her master's degree in business economics at Washington University and lived in St. Louis before going into teaching. Major League Baseball's program that pays for college is a leading factor in why the Walkers expressed a willingness, even eagerness, to have Jordan sign.</p><br><p>The assigned bonus for the 21st pick is $3,132,300.</p><br><p>Walker was able to play 16 games before the global pandemic halted sports at all levels, and he hit .457 with four homers and an OPS greater than 1.500. As a junior, Walker added more than 20 stolen bases to his 17 homers and that .519 average.</p><br><p>The Detroit Tigers selected Arizona State slugger Spencer Torkelson with the No. 1 pick.</p><br><p>The baseball-bashing Torkelson played first base in college, but the Tigers plan to move him to third. Detroit opened the draft for the second time in three years.</p><br><p>Torkelson hit 54 home runs at Arizona State and finished two shy of Bob Horner's school record.</p><br><p>Arkansas outfielder Heston Kjerstad went No. 2 to Baltimore after the Orioles took Oregon State catcher Adley Rutschman with the top pick a year ago.</p><br><p>Miami took Minnesota right-hander Max Meyer; Kansas City selected Texas A&M lefty Asa Lacy; Toronto went with Vanderbilt shortstop Austin Martin; Seattle chose Georgia righty Emerson Hancock; and Pittsburgh picked New Mexico State shortstop Nick Gonzales.</p><br><p>Tennessee high school outfielder Robert Hassell ended the run on college players, going No. 8 to San Diego. Florida high school outfielder Zac Veen was chosen by Colorado with the ninth pick, followed by the Los Angeles Angels selecting Louisville lefty Reid Detmers to round out the top 10.</p><br><p>The story contains material distributed by Tribune Content Agency, LLC, and The Associated Press.</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.advocatepress.com/subscribe?g2i_source=advocatepress.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://supportlocal.usatoday.com" target="_top">Support Local Businesses</a></li><li><a href="http://myprofile.advocatepress.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_AVP" target="_top">My Profile</a></li><li><a href="https://www.advocatepress.com/contact" target="_top">Contact Us</a></li><li><a href="https://www.advocatepress.com/submit" target="_blank">Online Forms</a></li><li><a href="https://www.advocatepress.com/section/?template=coupons" target="_blank">Coupons</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/iloln-classified/index.html" target="_blank">Place an Ad</a></li><li><a href="https://www.advocatepress.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.advocatepress.com/homes" target="_blank">Real Estate</a></li><li><a href="http://shopping.advocatepress.com/ROP/Categories.aspx" target="_blank">Shopping</a></li><li><a href="https://www.advocatepress.com/section/cars" target="_blank">Cars</a></li><li><a href="http://lakemedia.mo.newsmemory.com/specials_page2.php" target="_blank">Boats Magazine</a></li><li><a href="http://mediakit.gatehousemedia.com/Flora_IL" target="_top">Advertise With Us</a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://florail.govoffice2.com/" target="_blank">City of Flora</a></li><li><a href="http://www.florachamber.com/" target="_blank">Flora Chamber of Commerce</a></li><li><a href="http://www.claycountyillinois.org/" target="_blank">Clay County Government</a></li><li><a href="http://www.claycityschools.org/education/district/district.php?sectionid=699" target="_blank">Clay City School District</a></li><li><a href="http://www.floraschools.com/" target="_blank">Flora School District</a></li><li><a href="http://members.wabash.net/~northclay/index.html" target="_blank">North Clay School District</a></li></ul></div><div class="footer-col"><h4>Site Links<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.prairiestateoutdoors.com/" target="_blank">Prairie State Outdoors</a></li><li><a href="http://www.duquoin.com" target="_blank">Du Quoin</a></li><li><a href="http://www.carmitimes.com" target="_blank">Carmi Times</a></li><li><a href="http://www.dailyregister.com" target="_blank">Harrisburg Daily Register</a></li><li><a href="http://www.herrin-spokesman.com" target="_blank">Herrin Spokesman</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=IO&date=20200611&category=SPORTS&lopenr=200619908&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />The Clay County Advocate - Press-Flora, IL  ~ 105 West North Avenue, Flora, IL 62839<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.advocatepress.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.advocatepress.com/subscribe?g2i_source=advocatepress.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.advocatepress.com" target="_top">Home</a></li><li><a href="https://www.advocatepress.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"77"><a href="https://www.advocatepress.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"78"><a href="https://www.advocatepress.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"79"><a href="https://www.advocatepress.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"80"><a href="https://www.advocatepress.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"81"><a href="https://www.advocatepress.com/news/shareable" target="_top">Shareable</a></li><li id="navLink-TEST-"82"><a href="https://www.advocatepress.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"34529"><a href="http://elections.gatehousemedia.com/advocatepress/todaystopics/" target="_blank">Election 2016</a></li></ul></li><li><a href="https://www.advocatepress.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"85"><a href="https://www.advocatepress.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.advocatepress.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"88"><a href="https://www.advocatepress.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"89"><a href="https://www.advocatepress.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"90"><a href="https://www.advocatepress.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"91"><a href="https://www.advocatepress.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"38348"><a href="https://www.advocatepress.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.advocatepress.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52163"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"95"><a href="https://www.advocatepress.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"96"><a href="https://www.advocatepress.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"97"><a href="https://www.advocatepress.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"98"><a href="https://www.advocatepress.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"99"><a href="https://www.advocatepress.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"100"><a href="https://www.advocatepress.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"101"><a href="https://www.advocatepress.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"102"><a href="https://www.advocatepress.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.advocatepress.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"105"><a href="https://www.advocatepress.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"106"><a href="https://www.advocatepress.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"107"><a href="https://www.advocatepress.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.advocatepress.com/business-news" target="_top">Business</a></li><li><a href="https://www.advocatepress.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.advocatepress.com/photos" target="_top">Photos</a></li><li><a href="https://www.advocatepress.com/videos" target="_top">Videos</a></li><li><a href="https://www.advocatepress.com/calendar" target="_top">Calendar</a></li><li><a href="http://games.advocatepress.com" target="_top">Games</a></li><li><a href="https://www.advocatepress.com/contests" target="_top">Contests</a></li><li><a href="https://www.advocatepress.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.advocatepress.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.advocatepress.com/section/promoted//?prx_adpz=2234" target="_top">From Our Advertisers</a></li><li><a href="https://www.advocatepress.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.advocatepress.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_AVP" target="_top">My Profile</a></li><li><a href="https://www.advocatepress.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/ILOln" target="_top">Classifieds</a></li><li><a href="https://www.advocatepress.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.advocatepress.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.advocatepress.com/homes" target="_top">Homes</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/iloln-classified/index.html" target="_blank">Place an Ad</a></li><li><a href="http://mediakit.gatehousemedia.com/Flora_IL" target="_top">Advertise With Us</a></li><li><a href="https://www.advocatepress.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li><li><a href="http://advocatepress.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:editor@advocatepress.com">Feedback</a>
		</li>
		<li>
			<a href="https://www.advocatepress.com/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.advocatepress.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/ClayCountyAdvocatePress""
								target="_blank"
								title="The Clay County Advocate - Press-Flora, IL Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/CCAdvocatePress""
								target="_blank"
								title="The Clay County Advocate - Press-Flora, IL Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.advocatepress.com/section/feed"
								target="_blank"
								title="The Clay County Advocate - Press-Flora, IL RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.advocatepress.com/contact"
								title="Contact The Clay County Advocate - Press-Flora, IL">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
	        <a href="http://advocatepress.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.advocatepress.com/apps/pbcs.dll/article?avis=IO&date=20200611&category=SPORTS&lopenr=200619908&Ref=AR"}'>
	            Learn More
	        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.462/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-06-12&nbsp;01:58:11-->
	<script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=3&cb=1655797632"></script>
</body>
</html>
